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1   INTRODUCTION

Thank you for installing Geomagic Sculpt version 2017.0.

We are pleased to announce the availability of the new version of Geomagic Sculpt. 

Geomagic® Sculpt™ is a simple yet sophisticated precision voxel modeling software that enables you to create organic designs and 
edit and transform existing 3D data with sculpting, shaping and detailing tools not found in traditional CAD software.

This document outlines important information about this release. For information on what is new and improved in this version of 
Geomagic Sculpt, see New Features and Enhancements.

For more information about Geomagic Sculpt, please visit www.3dsystems.com/software/geomagic-freeform.

Check out the Customer Support website.

Customer Support can be reached via e-mail at Geomagic.Support.Americas@3DSystems.com.

COPYRIGHT
©1993-2017. 3D Systems, Inc. All rights reserved. The content of this manual is furnished for informational use only, is subject to 
change without notice, and should not be construed as a commitment by 3D Systems, Inc. This document is copyrighted and contains 
proprietary information that is the property of 3D Systems, Inc. 3D Systems and the 3D Systems logo, Geomagic, and Freeform are 
registered trademarks, Touch is a trademark of 3D Systems, Inc. Use of the 3dsystems.com and Geomagic.com website constitutes 
acceptance of its Terms of Service and Privacy Policy. Any names, places, and/or events in this publication are not intended to 
correspond or relate in any way to individuals, groups or associations. Any similarity or likeness of the names, places, and/or events 
in this publication to those of any individual, living or dead, place, event, or that of any group or association is purely coincidental and 
unintentional.

http://www.3dsystems.com/software/geomagic-freeform
http://support1.geomagic.com
mailto:Geomagic.Support.Americas%403DSystems.com?subject=
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2   INSTALLATION

SYSTEM REQUIREMENTS
For the latest system requirements information and to learn about specific qualified system configurations, choose Geomagic Sculpt, 
and from the Resource> Knowledgebase>Software FAQ section choose the System Requirements topic. Some users have had 
success running system configurations that deviate from the supported list. In such cases, these configurations are not officially 
supported by 3D Systems, Inc.

Additionally, we test a variety of hardware platforms in combination with the graphics subsystems . While we make every attempt to 
be as thorough as possible, hardware manufacturers change their products frequently and may be shipping newer products or have 
discontinued active support for others . Check the support section of the Web site for the latest system requirement information and 
specific qualified systems.

Supported Graphics Cards
For the most current list of graphics cards for use with the Geomagic Sculpt systems, choose Geomagic Sculpt, and from the 
Resource> Knowledgebase>Software FAQ section choose the System Requirements topic. Click on the link to expand the 
Recommended Graphics Cards. 

DOWNLOAD AND INSTALL SOFTWARE
You can download and install the software from gettingstarted.geomagic.com, select the Geomagic Sculpt product, then select to 
download Geomagic Sculpt.

In addition, automatic software updates are available if you selected Check for updated versions of the software in the 
Tools>Options>General>Updates dialog, a valid maintenance code is activated, and your computer is connected to the Internet. The 
application will check if a newer version is available and will download it automatically for installation.

If you have a Touch device attached and the Geomagic Touch Device Driver (GTDD) is installed, this option will also prompt you if 
there is an updated GTDD available to download. Deselect if you do not want to be informed that updated versions of the software are 
available.

ACTIVATE LICENSE
Geomagic Sculpt requires license activation to run the application on your PC. You can choose to use an evaluation license for a 15-
day period or activate a permanent license by using a virtual or physical dongle. 

After you start your application, the License Utility window opens. The License Utility allows you to activate and use the Geomagic 
Sculpt software.

NOTE: When you launch the License Utility, you can click the Help button to read the Licensing Guide. 

You should have received an email from 3D Systems with your activation code. If you have not received an email from 3D systems, 
contact them at Geomagic.Support.Americas@3DSystems.com.

If you are an existing user and have already activated the license on your PC with the previous version of the application, you can run 
the newer version of the application without re-activating the license. 

For more information, go to gettingstarted.geomagic.com, select the Geomagic Sculpt product, then click Licensing.

LICENSING AGREEMENT
Please see the End User License Agreement (EULA) located in the <Installation Directory>\Licenses for complete terms and conditions 
of the license. 

http://gettingstarted.geomagic.com
mailto:Geomagic.Support.Americas%403DSystems.com?subject=
http://gettingstarted.geomagic.com
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GEOMAGIC TOUCH DEVICE DRIVERS (GTDD)
This software is optimized to run with the latest version of the Geomagic Touch Device Driver. As this version of Geomagic Sculpt is 
released, the current Geomagic Touch Device Driver is v2016.10.13.  To  download and install the latest GTDD go to gettingstarted.
geomagic.com, select Geomagic Sculpt, select to download, and then select the most up-to-date device driver that is compatible with 
your device.

REQUIRED HARDWARE
Geomagic Sculpt v2017 requires a minimum display resolution of 1920 x 1080. Also, using custom desktop display settings that apply 
font and icon scaling may cause menu and dynabar contents to not fit properly. 

Geomagic Sculpt v2017 also minimally requires a graphics card with OpenGL 3 .0 support, and OpenGL 4.3 enables the software to 
provide additional performance enhancements.  

NOTE: You may receive a warning when you launch the product should either your card or driver not support OpenGL 3 .0 as required. 
If you receive the following warning, go to the manufacturer’s website and download the most recent driver .

.

NOTE:  Some older graphics cards may not have OpenGL 3.0 compatible drivers available. See your manufacturer’s 
options. 

When using cards and drivers that support OpenGL 4.3  you will be able to take advantage of the newer high resolution transparency 
options and improved framerates that are new to v2017.0. While the product may still run without this graphics capability, you will not 
experience the new capabilities .

For a list of the recommended graphics cards, go to the Support website, choose the Resource> Knowledgebase>Software FAQ  
section,  and choose the System Requirements topic.  

OPERATING SYSTEM
A 64-bit version of Windows 7, 8, or 10 is required to run this version of the software. 32-bit is no longer supported.

COMPATIBILITY WITH FREEFORM, AND FREEFORM PLUS FILES
This version of Geomagic Sculpt will open models that were created in older versions of Geomagic Sculpt, Freeform and Freeform Plus; 
however, models created in this version may not be compatible with previous versions (see notation under “Sketch Text” below). When 
a file is opened in Geomagic Sculpt, it is automatically converted to the current format. Once converted and saved, the model may lose 
compatibility with older versions of Geomagic Sculpt, Freeform and Freeform Plus . (See notation under “Sketch Text” below .)

WARNING: Not all geometry types supported in Freeform or Freeform Plus are supported in Geomagic Sculpt (for 
example, solids).  If you open a Freeform or Freeform Plus generated file which contains unsupported geometry 
types, only the Geomagic Sculpt supported objects will be retained on File>Open. If the updated file is saved without 
assigning a new filename to either the old or new file, the legacy file will be overwritten and the unsupported 
geometry will be lost.

We strongly recommend that you save backup copies of all files from previous versions of software before opening them in Geomagic 
Sculpt.

While it is expected that Geomagic Sculpt generated files can be opened by contemporary and future versions of software, this is 
something that is not tested and should be treated with appropriate caution, so be sure to save backup copies of all files before doing 
so.

INSTALLING MULTIPLE COPIES OF GEOMAGIC SCULPT SOFTWARE 
The Geomagic Sculpt v2017.0 installer allows for up to two side-by-side installations of the same major version or point release. For 
example, you can have one version of v2015 and the other version of v2017. However, only one can be run at a time.

http://gettingstarted.geomagic.com
http://gettingstarted.geomagic.com
http://Support1.Geomagic.com
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3   NEW FEATURES AND ENHANCEMENTS

The following is a summary of new features and enhancements in Geomagic Sculpt v2017. For a more comprehensive look at the new 
features and enhancements in the v2017 release see the online Help topic titled “What’s New?” You can access the help from within the 
Geomagic Sculpt application by pressing F1 or from the Help Menu.

NOTE: Customer-requested issues are noted with an *.

WHAT’S NEW IN 2017

Analysis Tools

Ruler: New Measure Angle Mode
The Ruler tool contains a new mode called “Measure Angle”. Assess angular measurements on your part by placing three points to 
specify the angle to be quantified. See Analysis Tools>Ruler>Measure Angle in the Freeform Help for more information.

Sketch Tools

Sketch Text Tool
The new Sketch Text tool allows you to create outline text profiles on a sketch plane.

This tool includes a text entry field and numerous settings to adjust height, spacing, alignment, and font. Sketch Text objects will be 
managed as single objects in the Object List, but can be exploded to letters, or further exploded to curves.  

Profiles can be used in many functions that extrude or emboss using profiles. Note that text strings saved as single objects in the 
Object List are not backwards compatible, and would need to be fully exploded to curves to be supported in older versions of Freeform. 
See Sketch Palette>Sketch Text in the Freeform Help for more information.
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Documentation

New Saved Views Features
Advanced documentation tools enable streamlined communication with your customers. Easily create images for downstream 
documentation with the click of a button. Generate a single image or sets of images based on orthographic views or the new turntable 
views mode. Utilize options that eliminate downstream editing time such as cropping, centering, object filtering, and background 
transparency when saving to PNG. See File Menu>Save View Images in the Freeform Help for more information.

 

Performance Optimizations

Reduce for Export
Multi-Piece Reduce-for-Export is now multi-threaded, reducing processing times by as much as 50% or more based on the processing 
of one piece per logical core.

Rendering Transparency for Clay (Voxels)
Optimizations to transparency has enabled framerate improvements, increases to rendering quality, and support for a choice of either 
High or Low Resolution rendering of Clay when using See Through mode. This allows for the best balance of quality and redraw 
performance in any workflow situation. Availability of this option requires a graphics card that supports OpenGL 4.3.

File>Save
Reduce file sizes by as much as 95% using optional File Compression on Save.  Note: files saved with compression are not backwards 
compatible to v2016.2 or prior.
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Additional New Features

Drag-n-Drop to Import [*.cly] files
A set of [*.cly] files can be selected and dragged into an open Freeform workspace, causing all the files to be imported into the same file 
session in Freeform.

New Function to Separate Discontiguous Mesh Shells
The Separate Shells function allows you to explode a mesh part that is comprised of numerous discontiguous shells into individual 
mesh pieces in the Object List. This tool functions in a manner similar to the pre-existing Wire Cut Clay tool and uses sketch profiles to 
cut away from, or inside of mesh pieces. See Object List>Mesh Context Menu>Mesh Utilities>Separate Shells in the Freeform Help for 
more information.

New Export Model as [*.cly] Options
The Export Model Dialog for export of [*.cly] files contains new preferences that allow for such things as exploding sketch profiles, 
demoting Solid Pieces, and applying compression upon export of .cly files. See File Menu>Export Model in the Freeform Help for more 
information.

 

Tessellation Management for Solid-to-Mesh Conversions
New mesh tessellation controls are now provided in several functions where solids are converted to mesh, such as on import of a CAD 
part as mesh.

Multiple Piece Boolean Removal Enhancements
The Object List Boolean Remove function has been enhanced. The Boolean function can switch the tool and target by using the CTRL 
ke modifier. Using the CTRL key modifier, Multiple pieces may now be removed from one target piece, as opposed to the default 
behavior where the selection set is removed from the target piece. See Object List>Context Menu>Boolean in the Freeform Help for 
more information.
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New Preferences to Control File Display in Freeform Viewer
The Save File options now include the ability to set some file attributes that affect the way a file is displayed in the Freeform Viewer. The 
specified settings will affect whether certain file attributes are shown when the file is opened in the v2017 Freeform Viewer application. 

4   BUG FIXES

NOTE: Customer-reported issues that have been resolved are noted with an *.

BUG FIXES IN 2017
This section lists issues that have been resolved since v2016.2:

•	 GF-286: Integrated Intel Graphics Cards: “About Your Computer” Reports incorrect video card on laptop with integrated and dis-
crete graphics *

•	 GF-331: Haptic Communication Loss when using KeyShot at the same time as Freeform with ethernet connected devices. (Key-
shot defaults to use all cores). Adding note to doc on how to set max cores utilized within Keyshot.

•	 GF-2087: Emboss with Image: Resize handles (corner arrows) do not stay fixed to plane corners(regression). (Fixed in Haptic 
Mode for v2017) *

•	 GF-3237: Printability Checking: Printing Volume - White box edge colors alters when enabling perspective view

•	 GF-3284: SubD: Rendering artifact when you undo edits made to divided (not promoted) cage that are outside of the bounding box 
of the cage
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•	 GF-3430: Keyshot: Live Linking error on terminating process in task manager, must restart Keyshot through Program Files

•	 GF-3793: Sketch: Offset - Fails silently with large distance...need error message when result would be negative width/height

•	 GF-3821: Sketch: Offset Tool - Offset did not create properly for this case (Offset is attempted using distance that exceeds radius 
of arc)

•	 GF-4531: Export of stitched BREP:  U3D exporting issues takes a long time. Add warning and integrate ESC functionality. 

•	 GF-4837: Emboss with Wrapped Image tool:  Settings no longer persistent on return to tool (regression from v2015) *

•	 GF-4896: Graphics: Windows 10 - Redraw and ghosting issues when dragging floating windows when connected to multiple dis-
plays

•	 GF-5017: Tools/Options: Save Screen: Save View JPEG Files - Global pref altered when applying local change via File menu

•	 GF-5224: Emboss along Curve: Problems loading 10k image

•	 GF-5312: Custom Carve Tool: Toolhead scaling occurs in cases where the toolhead profile center is not coincident to the Plane 
center

•	 GF-5313: Custom Carve Tool: Creation of custom carve tool sometimes fails when the tool handle is coincident to the edge of tool 
head

•	 GF-5317: Export Selected Meshes to Mesh:  Export to color carrying filetypes currently captures the green selection color

•	 GF-5335:  Import to Plane:  Import of AI file from Illustrator (CC 15) fails with the stroked path warning ( outlined, stroked , pdf 
compatible)

•	 GF-5346: Import to Plane: Help access in dynabar  not triggering the Help topic  

•	 GF-5380: 3d Curves:  Performance Regression - Framerate issue being seen as cursor traverses over an existing curve’s bound-
ing box

•	 GF-5384: Performance - Mainline regression where manipulating the clay piece causes application to be come unresponsive for 
several seconds

•	 GF-5420: Object List:  OL selection state lost in the OL after collapsing/expanding folder...though still selected in the scene

•	 GF-5631: Copy to Clay: Case where converted clay model does not match surface of original mesh *

•	 GF-5640: OL Folderization Issue (e.g. Sketch Text Tool): Undo/Redo outside of sketch removes folders in OL window

•	 GF-5652: Sketch Sub-folder: Tools can select profiles that are in hidden sub-folders

•	 GF-5654: Draw Curve: 3D curve drawing snaps to hidden sketch objects (affects mouse only or haptic modes)

•	 GF-5665: Inflate: Choppy edges in preview and final results on applied, regression from FFv15

•	 GF-5803: Sketch: Select Sketch Object - Editing a Freehand sketch curve after changing the Edit Points option causes an endpoint 
to jump

•	 GF-5845: Ruler: Crash on File/New while in a session of Ruler that is layered over the sketch text tool 

•	 GF-5882: Plane Intersection Curve: In single slice mode the “sketch curve” option does not work

•	 GF-5905: Draw Curve: Fit Curve - Nodes of a curve are not placed correctly on a moved piece when using the mouse

•	 GF-5909: Sketch: MRS - Import .dxf does not select object in MRS tool

•	 GF-5949: View Manipulation Widget: Rendering Anomaly surrounds the mouse driven cursor as it passes over the widget’s back-
ground (skew of view affects behavior)

•	 GF-5979: Rendering: Plane - Change in the way a plane is rendered for an active piece when a SubD piece is also visible

•	 GF-6019: Reposition Piece tool: Cannot use the down elevator button with a .001mm increment *

•	 GF-6024: Pose: Crash placing pivot on cylinder top face with Auto Center ON, regressed from 16.2 release

•	 GF-6039: View Manipulation Widget: Axis labels render as colored squares

•	 GF-6045: Mirror Rectangle and sketch plane is not resized *

•	 GF-6052: Slice Deform Clay: Crash Scenario Found *

•	 GF-6091: OL: Show/Hide eyeball - Ctrl selecting a Plane and a Sketch created on that plane, will not unhide the sketch if the eye-
ball is turned on 

•	 GF-6092: OL: Hide/Show Eyeball - Sketch Text object visibility state does not match scene

•	 GF-6121: Ruler: Crash on file new interrupting ruler mid way

•	 GF-6126: Save Turntable Views to Files - dropping pixels with transparency enabled

•	 GF-6130: Sketch Mirror: Extra sketch object created on File/Save

•	 GF-6131: Sketch: Mirror, Circular & Rectangular Arrays - File save not recognized, on exit app prompts user to save 

•	 GF-6132: Export: PDF - Scale or zoom issue when Freeform is set to inches *
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•	 GF-6166: Rendering: New transparency - Coincident and intersecting piece surfaces not displayed with as much back facing edge 
and surface data *

•	 GF-6180: Reduce for Export (haptics): After decimation - haptic cannot access outside of the main window *



5   KNOWN ISSUES

KNOWN ISSUES IN 2017
This section lists issues that have been identified in version 2017.

•	 GF-323: Repositioning with Precise Movement: Precise Movement is invoking an offsetting behavior. This issue particularly notice-
able if axis snap is on.
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