
Release Notes

The Fastest Path from 3D Scans  
to Your CAD Software

Geomagic® Design X™



Software: Geomagic Design X
Version 2016.2.0

Release Date: January 2018

TABLE OF CONTENTS

1 INTRODUCTION 1
COPYRIGHT 1

2 INSTALLATION 2
SYSTEM REQUIREMENTS 2
DOWNLOAD AND INSTALL SOFTWARE 2
ACTIVATE LICENSE 2

3 NEW FEATURES AND ENHANCEMENTS 3
WHAT’S NEW IN 2016.2.0 3

Clipping Plane in LiveScan 3
New Coordinate Orientation 3
Improved Patch Network Repair 4
Enhancements 5

WHAT’S NEW IN 2016.1.1 6
New File format support 6
Enhancements 6

WHAT’S NEW IN 2016.1.0 7
The Faro Array Imager support 7
New CAD Versions Support in LiveTransferTM 7

Performance Improvements 7
Temporary Folder for Scanning 8
New File format support 8

4 FIXED BUGS 9
BUG FIXES IN 2016.2.0 9
BUG FIXES IN 2016.1.1 9
BUG FIXES IN 2016.1.0 9



3D Systems, Inc. 1

1 INTRODUCTION

We are pleased to announce the availability of the new version of Geomagic Design X. Geomagic Design X is the only reverse 
engineering software that combines history-based CAD with 3D scan data processing so you can create feature-based, editable solid 
models compatible with your existing CAD software.

New features in this release were made to deliver intuitive and efficient user experiences. Work more productively with a new Ribbon 
UI. This release also includes many more enhancements and some bug fixes.

For more information, please visit www.geomagic.com.

COPYRIGHT
©1993-2018. 3D Systems, Inc. All rights reserved. The content of this manual is furnished for informational use only, is subject to 
change without notice, and should not be construed as a commitment by 3D Systems, Inc. Any names, places, and/or events in this 
publication are not intended to correspond or relate in any way to individuals, groups or associations. Any similarity or likeness of 
the names, places, and/or events in this publication to those of any individual, living or dead, place, event, or that of any group or 
association is purely coincidental and unintentional.

http://www.geomagic.com
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2 INSTALLATION

SYSTEM REQUIREMENTS
For the latest system requirements information and to learn about specific qualified system configurations, go to the System 
Requirements page in the Geomagic Support Center. Some users have had success running system configurations that deviate from 
the supported listed on our website. In such cases, these configurations are not officially supported by 3D Systems, Inc.

Additionally, we test a variety of hardware platforms in combination with the graphics subsystems. While we make every attempt to 
be as thorough as possible, hardware manufacturers change their products frequently and may be shipping newer products or have 
discontinued active support for others. Check the support section of the website for the latest system requirement information and 
specific qualified systems.

DOWNLOAD AND INSTALL SOFTWARE
You can download and install the software from gettingstarted.geomagic.com, select the Geomagic Design X product, then select to 
download Geomagic Design X.

In addition, automatic software updates are available if you set the Update Product Automatically option to True in Preferences and 
a valid maintenance code is activated, and your computer is connected to the Internet. The application will check if a newer version is 
available and will download it automatically for installation.

You can also manually check if a newer version is available by going to Help > Check For Update.

ACTIVATE LICENSE
Geomagic Design X requires license activation to run the application on your PC. You can choose to use an evaluation license for a 15-
day period or activate a permanent license by using an Online Activation license or a physical dongle. 

After you start your application, the License Utility window opens. The License Utility allows you to activate and use the Geomagic 
Design X software.

NOTE: When you launch the License Utility, you can click the Help button to read the Licensing Guide. 
You should have received an email from 3D Systems with your activation code. If you have not received an email from 3D systems, 
contact them at Geomagic.Support.Americas@3DSystems.com.

If you are an existing user and have already activated the license on your PC with the previous version of the application, you can run 
the newer version of the application without re-activating the license. 

For more information, go to gettingstarted.geomagic.com, select the Geomagic Design X product, then click Licensing.

http://support1.geomagic.com/link/portal/5605/5668/Article/1161/-What-are-the-system-requirements-for-Geomagic-Solutions-software
http://support1.geomagic.com/link/portal/5605/5668/Article/1161/-What-are-the-system-requirements-for-Geomagic-Solutions-software
http://gettingstarted.geomagic.com
mailto:Geomagic.Support.Americas%403DSystems.com?subject=
http://gettingstarted.geomagic.com
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3 NEW FEATURES AND ENHANCEMENTS

WHAT’S NEW IN 2016.2.0

Clipping Plane in LiveScan
Added a new Use Clipping Plane option in the LiveScan command. This option allows you to set a location of a plane and use it to 
automatically clip scanned floor area out of acquired data while scanning an object using the LiveScan. If a target object is placed on a 
stable plate, you can capture floor area and set a location of a clipping plane directly on it using the Capture Plane option.

See Insert > Scanner Direct Control > LiveScan(TM) in the Geomagic Design X Help for more information.

New Coordinate Orientation
In the Preferences, in the General tab, in the Viewing section, a new Front View Orientation option has been added. This allows you 
to specify the orientation of the Front View in either of Y-Up or Z-Up direction as you desired.

Front View (Y-Up) Front View (Z-Up)
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Improved Patch Network Repair

Relaxing Contour Curves
A new Relax Contour command has been added to the Tools > 3D Sketch Entities menu. This tool allows you to relax designed 
contour curves and quickly rebuild them as smooth contour curves on a target mesh. This is also available in the Create/Edit Patch 
Network group on the SURFACING tab.

See Tools > 3D Sketch Entities > Relax Contour Curves in the Geomagic Design X Help for more information.

Designed Contour Curves Relaxed Contour Curves

Repairing Patch Curves
A new Repair Patches command has been added to the Tools > 3D Sketch Entities menu. This tool allows you to detect and repair 
poor network topology of patch curves on a target mesh.

The following defects are detectable:

• Intersection Paths • High Degree Corners
• Poor Patch Angles • High Deviation Patches

This is also available in the Create/Edit Patch Network group on the SURFACING tab.

See Tools > 3D Sketch Entities > Repair Patch Curves in the Geomagic Design X Help for more information.

Removing Patch Curves
A new Remove Patches command has been added to the Tools > 3D Sketch Entities menu. This tool allows you to remove all 
designed patch curves at a time. This is also available in the Create/Edit Patch Network group on the SURFACING tab.

See Tools > 3D Sketch Entities > Remove Patch Curves in the Geomagic Design X Help for more information.

Note: This tool will keep designed contour curves so that they can be used to create a patch network.

Relaxing Patch Curves
A new Relax Patches command has been added to the Tools > 3D Sketch Entities menu. This tool allows you to relax designed patch 
curves and quickly rebuild them as smooth patch curves on a target mesh. This is also available in the Create/Edit Patch Network group 
on the SURFACING tab.

See Tools > 3D Sketch Entities > Relax Patch Curves in the Geomagic Design X Help for more information.

Designed Patch Curves Relaxed Patch Curves
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Enhancements

Updated LiveTransfer
Newer versions of supported CAD systems have been added to the LiveTransfer.
The following is the CAD systems newly added to the LiveTransfer:

• SOLIDWORKS 2017

• SOLIDWORKS 2018

• Autodesk Inventor 2017

• Autodesk Inventor 2018

• PTC Creo 3

• PTC Creo 4

Enhancements of Fit Surface Patches
While defining sharp edges in the Fit Surface Patches tool, various manual selections are available. In addition to selecting continuous 
contours, you can select all designed contours at a time or select a single contour line in a specific patch.

Additionally, with a new Separate Surface Patches By Contour Loop option, you can separate fitting surface patches by contour loop 
and create individual surface bodies.

New 3D Spline Constraint Icon
While drawing a 3D spline, different constraint icons depending on where you draw on will appear next to the cursor. This helps you 
draw a 3D spline in a 3D space recognizing which existing entities can constraint a node of the curve.

Improved Healing Wizard 
The Healing Wizard has been improved for better post-processing. With the improved Healing Wizard, you can create a free-defect 
mesh model for enhanced surface fitting results. 

Previewing Results of Smooth Boundary in Fill Holes
In the Fill Holes, you can now control smoothness of boundary and preview the changes in the boundary before filling holes.
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Importing Files 
Improved compatibility of Importing CAD, PLY, ASCII, and e57 files.

Crash Reporting Tool
When you encounter a program crash, you can create a bug report with a .DMP file and send it to 3D Systems to help resolve the 
issue.

Updated Hardware Device Compatibility
Compatibility with the following scanning devices has been updated: AICON, FARO, Kreon, and Nikon devices.

WHAT’S NEW IN 2016.1.1

New File format support

Importing GPD Files
Geomagic Design X now supports the Geomagic Point Data file format (.gpd). The GPD is ordered points file format, and can contain 
point data with color and normal information. See Insert > Import in the Design X Help for more information.

Enhancements

Scanning Performance
The performance of scanning using LiveScan, as well as post-scanning processing has been greatly enhanced. You will now 
experience a much faster scanning experience.

Upgraded Licensing platform and Installer
The licensing platform has been updated so that it enhances security and robustness, as well as displays the license type in the title 
bar.

Importing / Exporting PLY File Format
The PLY file format has been updated to allow importing and exporting of points with normal information, if the data type is points.

Anonymous Usage Statistics
Added an optional feature to allow the collection of anonymous usage statistics to improve the product and user experience.
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WHAT’S NEW IN 2016.1.0

The Faro Array Imager support
Geomagic Design X 2016.1.0 now supports the FARO Array Imager.

The FARO Array Imager is a high performance non-contact 3D imaging system, capable of collecting millions of points in just seconds. 
Using blue-light projection technology, the FARO Array Imager achieves high accuracy point cloud data on parts, assemblies, and tools 
for inspection and reverse engineering applications.

See Insert > Scanner Direct Control > Faro Array Imager in the Design X Help for more information.

(Source : FARO, www.faro.com)

New CAD Versions Support in LiveTransferTM

The LiveTransfer has been improved to support newest versions of CAD applications. 

The following is a list of CAD versions newly supported in LiveTransfer.

• SolidWorks 2016

• SIEMENS NX 8.5 / 9 / 10

• Creo(Pro/E) 3.0
See “LiveTransfer(TM)” in the Design X Help for more information.

Performance Improvements

Modeling Performance
Improved modeling performance for better your work environment. Regardless of the number of modeling features, you can maintain 
stable modeling performance in your design works.

Scanning Performance
Improved scanning performance to provide better user experience in scanning with high-resolution scanning devices such as FARO HD 
ScanArm.

http://www.faro.com
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Temporary Folder for Scanning
Improved to better support sustainable scanning process using Geomagic Capture 3D scanner. In Geomagic Capture application, you 
can now set the path of a temporary folder where temporary files are stored during the scanning. For more information, click “Help” from 
the Geomagic Capture plug-in to open the Geomagic Capture User’s Guide.

New File format support

Importing E57 Files
The E57 file format (.e57) is now supported. The E57 file format is an extensible industry standard for 3D Imaging Data developed by 
ASTM International and specified in the ‘ASTM E2807 - 11 Standard Specification for 3D Imaging Data Exchange’ standard.

The E57 file format stores data in a combination of binary and XML for Laser Scanners/ Radars (LADAR), Optical Range Cameras 
(Flash LADAR) and LIDAR images. This file format can contain point data with normal and color information.

See Insert > Import in the Design X Help for more information.

Importing Lsproj Files
The Lsproj file format (.lsproj) is now supported. This is FARO SCENE project file format, can contain point data with normal and color 
information. See Insert > Import in the Design X Help for more information.
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4 FIXED BUGS

BUG FIXES IN 2016.2.0
This section lists issues that have been resolved since Geomagic Design X v2016.1.1:

• GDX-3085: Fixed an issue where in a specific scenario, LiveScan filtering behaved incorrectly.
• GDX-3086: Fixed an issue where the incorrect normals were calculated during LiveScan.
• GDX-3082: Fixed an issue where in some cases, scan passes were assigned a different color.

• GDX-3011: Fixed an issue where the Minimum Distance Threshold for continuous probing could not be set below a 
certain value.

• GDX-3047: Fixed an issue where in specific scenario using the Axis Constraint option, extracted planes would not 
properly transfer to SOLIDWORKS.

• GDX-3250:
The software would crash during a LiveTransfer to Inventor if Inventor’s “Startup Action” was enabled. 
The software no longer crashes and provides an error message instead. Inventor’s “Startup Action” is 
not supported.

• GDX-2978: Fixed an issue where Transform Body by using Local Coordinate would not display the correct 
manipulator.

• GDX-2993: Fixed the crash dialog to direct users to the correct support website.
• GDX-2769: Fixed an issue where users would receive a JavaScript error when launching the software.
• GDX-3079: Fixed an issue where sometimes running the Healing Wizard would result in a crash.

• GDX-2789: The visibility preferences of Measurement were not remembered when users opened native files. This 
has been resolved.

BUG FIXES IN 2016.1.1
This section lists issues that have been resolved since Geomagic Design X v2016.1.0:

• GDX-2673: Fixed an issue where the ‘:’ character in Mesh name prevented export
• GDX-2801: Improved .3pi file import results
• GDX-2737: Fixed an issue where in some cases, Faro FLS files could not be imported
• GDX-2720: Improved performance for AMD graphic cards by default preferences
• GDX-2791: Fixed an issue where sometimes target or rotary alignments would fail.
• GDX-2803: Updated the FARO 3D Imager name to Faro Cobalt Array Imager
• GDX-2682: Renamed LDI interface to Laser Design Surveyor Scanner
• GDX-2831: Improved forced removal of empty folder during installation
• GDX-2742: Fixed an issue where Redistributable packages were unintentionally removed 
• GDX-1843: Removed duplicate files during installation 
• GDX-2869: Fixed an issue where in some cases, ghost scans are visible after LiveScan.
• GDX-2823, GDX-

2733, GDX-2711:
Minor language translations fixed

• GDX-2789: The visibility preference of “Measurements” are preserved on re-open of a file

BUG FIXES IN 2016.1.0
This section lists issues that have been resolved since Geomagic Design X v2016.0.1:

• GDX-2428: The Cube Maps in the Environment mapping have left and right image mixed up.
• GDX-2439: In the Auto Surface, in the Mechanical method, the Target Patch Count does not work properly.
• GDX-2441: The application crashes when editing radius in the Variable fillet.

• GDX-2465: The application crashes when attempting to align point clouds, which do not have normal information, 
with the Do Not Align Between Moving Object option.

• GDX-2480: The Linear Pattern and Circular Pattern Modeling Features are registered with wrong names in the 
Feature Tree.

• GDX-2431: The application crashes when using the Sweep Wizard in a certain model.

• GDX-2498: An entity was accidentally copied just by holding the Ctrl key and picking the entity with a slight mouse 
move.
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